package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(tags:)`)
var str = `---
anykey: somevalue
tags:
- sometag
- sometag2
anyotheryamlkey: somevalue
anyotheryamlkey2:
- somevalue1
---
Main body text.
More text.`
var substitution = "$1\n - m/diary"
fmt.Println(re.ReplaceAllString(str, substitution))
}