use strict;
my $str = '---
anykey: somevalue
tags:
- sometag
- sometag2
anyotheryamlkey: somevalue
anyotheryamlkey2:
- somevalue1
---
Main body text.
More text.';
my $regex = qr/(tags:)/mp;
my $subst = '$1\\n - m/diary';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";