#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)<a href="javascript:void\(0\)"[^>]*>(.*?)id="sw-slots-grid-line-break""
Local $sString = "<div id="tmm-grid-swatch-HARDCOVER" class="a-column a-span6 a-text-left swatchElement selected celwidget" role="listitem" data-csa-c-id="rqzqyx-arj8qg-jifnrc-pelgtz" data-cel-widget="tmm-grid-swatch-HARDCOVER"> <span class="a-button a-button-selected a-spacing-none a-button-toggle format" id="a-autoid-2"><span class="a-button-inner"><a href="javascript:void(0)" role="radio" aria-checked="true" aria-current="page" class="a-button-text a-text-left" id="a-autoid-2-announce"> <span class="slot-title">" & @CRLF & _
" <span aria-label="Hardcover Format:">Hardcover</span> <br> </span>" & @CRLF & _
" <span class="slot-price">" & @CRLF & _
" <span aria-label="$16.94" class="a-size-base a-color-price a-color-price"> $16.94 </span> </span>" & @CRLF & _
" <br id="sw-slots-grid-line-break">" & @CRLF & _
"" & @CRLF & _
" </a></span></span> </div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")