use strict;
my $str = '<div id="tmm-grid-swatch-HARDCOVER" class="a-column a-span6 a-text-left swatchElement selected celwidget" role="listitem" data-csa-c-id="rqzqyx-arj8qg-jifnrc-pelgtz" data-cel-widget="tmm-grid-swatch-HARDCOVER"> <span class="a-button a-button-selected a-spacing-none a-button-toggle format" id="a-autoid-2"><span class="a-button-inner"><a href="javascript:void(0)" role="radio" aria-checked="true" aria-current="page" class="a-button-text a-text-left" id="a-autoid-2-announce"> <span class="slot-title">
<span aria-label="Hardcover Format:">Hardcover</span> <br> </span>
<span class="slot-price">
<span aria-label="$16.94" class="a-size-base a-color-price a-color-price"> $16.94 </span> </span>
<br id="sw-slots-grid-line-break">
</a></span></span> </div>';
my $regex = qr/<a href="javascript:void\(0\)"[^>]*>(.*?)id="sw-slots-grid-line-break"/isp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}