#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(?=.*\bhede\b)).*$"
Local $sString = "hoho" & @CRLF & _
"hihi" & @CRLF & _
"haha" & @CRLF & _
"hede" & @CRLF & _
"some words before hoho some words after that" & @CRLF & _
"some words before hihi some words after that" & @CRLF & _
"some words before haha some words after that" & @CRLF & _
"some words before hede some words after that" & @CRLF & _
"ahede"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")