const regex = /^(?!(?=.*\bhede\b)).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(?=.*\\bhede\\b)).*$', 'gm')
const str = `hoho
hihi
haha
hede
some words before hoho some words after that
some words before hihi some words after that
some words before haha some words after that
some words before hede some words after that
ahede`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}