import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[8]*(?:1[8]*[8]?0|0[8]*[8]?1)[8]*\\b";
final String string = "0188\n"
+ "0818\n"
+ "0881\n"
+ "1088\n"
+ "1808\n"
+ "1880\n"
+ "8018\n"
+ "8081\n"
+ "8108\n"
+ "8180\n"
+ "8801\n"
+ "8810\n"
+ "01\n"
+ "801\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}