package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)b\d{4}\s[a-zA-Z]{3,4}(-\d)?`)
var str = `D b1308 pspE; thiosulfate sulfurtransferase PspE K03972 pspE; phage shock protein E
B 09193 Unclassified: signaling and cellular processes-6
C 99977 Transport
D b2347 yfdC; inner membrane protein YfdC K21990 yfdC; formate-nitrite transporter family protein
D b3657 yicJ; putative xyloside transporter YicJ K03292 TC.GPH; glycoside/pentoside/hexuronide:cation symporter, GPH family
D b3876 yihO; putative sulfoquinovose transporter K03292 TC.GPH; glycoside/pentoside/hexuronide:cation symporter, GPH family
D b0361 insD-1; IS2 element protein K07497 K07497; putative transposase
D b1402 insD-2; IS2 insertion element protein InsB K07497 K07497; putative transposase`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}