$re = '/subcategory\.html\?.*id=(.*?)&(.*title=(.+)?)?/m';
$str = 'http://example.com/xyz/subcategory.html?id=3000080292&backTitle=Back&title=BabySale
http://example.com/xyz/subcategory.html?id=3000080292&backTitle=Back&';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);