#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z]+ ([A-Z]* )?([A-Z]+)\n(([A-Z|0-9]*)+ ([A-Z|0-9]* ?)*)?\n([A-Z|0-9)]* )*[A-Z|0-9)]*\n([A-Z|0-9)]* ){1,3}(A[LKSZRAP]|C[AOT]|D[EC]|F[LM]|G[AU]|HI|I[ADL N]|K[SY]|LA|M[ADEHINOPST]|N[CDEHJMVY]|O[HKR]|P[ARW]|RI|S[CD] |T[NX]|UT|V[AIT]|W[AIVY]) [0-9]{5}"
Local $sString = "JANE DOE DOE" & @CRLF & _
"COMPANY1 ASSOCIATES HUB" & @CRLF & _
"1960 W CHELSEA AVE STE 2006R" & @CRLF & _
"NEW YORK NY 84054"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")