#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(https:|http:|www\.)\S*"
Local $sString = "3333-768-0948" & @CRLF & _
"1133.168.0248" & @CRLF & _
"7678*999-8978" & @CRLF & _
"" & @CRLF & _
"https://google.com/q=search " & @CRLF & _
"http://google.com/q=search " & @CRLF & _
"httpq://google.com/q=search " & @CRLF & _
"www.google.com" & @CRLF & _
"www.google.com/?search=qppoao" & @CRLF & _
"www . google.com/?search=qppoao" & @CRLF & _
"https : //google.com/q=search" & @CRLF & _
"" & @CRLF & _
"https://www.google.com" & @CRLF & _
"http://www.google.com" & @CRLF & _
"www.google.com" & @CRLF & _
"htt://www.google.com" & @CRLF & _
"://www.google.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")