use strict;
my $str = '3333-768-0948
1133.168.0248
7678*999-8978
https://google.com/q=search
http://google.com/q=search
httpq://google.com/q=search
www.google.com
www.google.com/?search=qppoao
www . google.com/?search=qppoao
https : //google.com/q=search
https://www.google.com
http://www.google.com
www.google.com
htt://www.google.com
://www.google.com';
my $regex = qr/^(https:|http:|www\.)\S*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}