$re = '/^(https:|http:|www\.)\S*/m';
$str = '3333-768-0948
1133.168.0248
7678*999-8978
https://google.com/q=search
http://google.com/q=search
httpq://google.com/q=search
www.google.com
www.google.com/?search=qppoao
www . google.com/?search=qppoao
https : //google.com/q=search
https://www.google.com
http://www.google.com
www.google.com
htt://www.google.com
://www.google.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);