# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(https:|http:|www\.)\S*"
test_str = ("3333-768-0948\n"
"1133.168.0248\n"
"7678*999-8978\n\n"
"https://google.com/q=search \n"
"http://google.com/q=search \n"
"httpq://google.com/q=search \n"
"www.google.com\n"
"www.google.com/?search=qppoao\n"
"www . google.com/?search=qppoao\n"
"https : //google.com/q=search\n\n"
"https://www.google.com\n"
"http://www.google.com\n"
"www.google.com\n"
"htt://www.google.com\n"
"://www.google.com")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.