#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\[(/?\w+)]"
Local $sString = " This is a [;;Text] and I want to match [center]everything without ;;[/center]"
Local $sSubst = "<$1>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)