import Foundation
let pattern = #"\[(/?\w+)]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #" This is a [;;Text] and I want to match [center]everything without ;;[/center]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<$1>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)