$re = '/\bsection\s*\d+(?:\.\d+)*:/m';
$str = 'section 1.1: Disability ........';
$subst = "<hr/>$0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;