using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^Linus::[^\n:]*(?::(?::CASE|(?!:))[^\n:]*)*";
string input = @"Linus::AOPKNS::CASE::CASE
Linus::AOP::KNS::CASE
Linus::AOPKNS::CASE
Linus::AOPKNS
Linus::AOPKNS::OK";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}