use strict;
my $str = 'https://www.facebook.org/hello
http://www.xxxx.wordpress.com/hello
http://www.xxxx.yyy.zzz.wordpress.com/hello';
my $regex = qr/(https?:\/\/)?([w]{3}\.)?(\w*.\w*)([\/\w]*)/mip;
my $subst = '$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";