package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{3}-){2}\d{3} \d{2}$`)
var str = `123-456-789 00
234-363-464 66`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}