package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)(\s+|^)(ADD|CHANGE|MODIFY)\b(\s+COLUMN)?((\s|.)*(BEFORE|AFTER))`)
var str = `add
column asd asd asd
asdasd after `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}