using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\?(?:&?([a-z=]+)(?![a-z=])){3}.*$";
string input = @"?some=querystring&ssembly=containing&n=indeterminate&mount=of&ll=potentially&ccordant=matches
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}