# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\{\{([^\}]+)\}\})\n\{\{\2\}\}/$1/;t' <<< "===Verb===
{{eu-verb}}
{{eu-verb}}
test"