$re = '/(\{\{([^\}]+)\}\})\n\{\{\2\}\}/';
$str = '===Verb===
{{eu-verb}}
{{eu-verb}}
test';
$subst = "$1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;