re = /(\{\{([^\}]+)\}\})\n\{\{\2\}\}/
str = '===Verb===
{{eu-verb}}
{{eu-verb}}
test'
subst = '$1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result