$re = '/^(\d{1,2}|\d{1,2}\.\d{1,2}|100\.[0]{1,2}|100)$/m';
$str = '0
0.00
0.769
767.99
88.75
100.00
5
65
00
000
00.00
12
100.22
100.
100
sad
0w
0.
.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);