re = /dark:\w+([-:\w]*\w)/m
str = '<button class="dark:text-white text-black">My Button</button>
<button class="text-black dark:text-white text-black">My Button</button>
<button class="text-black dark:text-white">My Button</button>
<button class="[&[data-test]]:dark:text-white text-black">My Button</button>
<button class="text-black [&[data-test]]:dark:text-white text-black">My Button</button>
<button class="text-black [&[data-test]]:dark:text-white">My Button</button>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end