import Foundation
let pattern = #"dark:\w+([-:\w]*\w)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<button class="dark:text-white text-black">My Button</button>
<button class="text-black dark:text-white text-black">My Button</button>
<button class="text-black dark:text-white">My Button</button>
<button class="[&[data-test]]:dark:text-white text-black">My Button</button>
<button class="text-black [&[data-test]]:dark:text-white text-black">My Button</button>
<button class="text-black [&[data-test]]:dark:text-white">My Button</button>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)