$re = '/\$\d+/m';
$str = 'foo$12___bar___$34wilma buzz';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;