using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\?[^?]*)+";
string substitution = @"$1";
string input = @"localhost.com/en_ar/body?abcd?products_type=235&treatment=132?product_type=235&treatment=132&__from_store=en_bh";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}