re = /^(?!SS|FF|PP).*(\d{1,2}[,.]\d{1,2})$/m
str = 'CC 1,00
SS 1,00
PP 1,00
1,00
FF 1,00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end