$re = '/(?<!\bfor\s)€(\d+(?:,\d+)?)/m';
$str = 'discount of €50,20 on these items
This item on sale now for €30,20';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);