import re
regex = re.compile(r"(\<)([A-Za-z0-9_!]+)(.*?)(\>)", flags=re.MULTILINE)
test_str = ("<html>\n"
"<body>\n"
"<h1>Aqui cabeçalho do arquivo</h1>\n"
"<p>Meu parágrafo da página web.</p>\n"
"<p>Meu segundo parágrafo.</p>\n"
"</body>\n"
"</html>\n"
"<p>\n\n"
"<html></html>\n\n"
"<!DOCTYPE>\n"
"<input href=\"\"/>\n"
"<button type=\"submit\"></button>\n"
"<button></button>\n\n\n"
"Aenean lacinia bibendum <a href=\"/life\">life</a> sed consectetur. <a href=\"/work\">Work</a> quis risus eget urna mollis ornare <a href=\"/about\">about</a> leo.\n\n"
"<br/>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")