$re = '/^.* Test .* recorded an issue at ([a-zA-Z0-9_\/ ]+\.swift):([0-9]+):([0-9]+):/m';
$str = ' Test assignTimes_withExplicitAtEnd_assignsBeforeExplicit() recorded an issue at CanvasTimeAssignmentTests.swift:97:3: Expectation failed:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);