// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)export type \w+ =(?: (\S+))?(?:\s+\| (\S+))*;").unwrap();
let string = "export type RegistrationMode = \"Closed\" | \"RequireApplication\" | \"Open\";
export type SearchType =
| \"All\"
| \"Comments\"
| \"Posts\"
| \"Communities\"
| \"Users\"
| \"Url\";";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}