import Foundation
let pattern = #"(AAA|BBB|CCC|DDD)\((([^()]*|\([^()]*\))*)\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
one two 12AAA(CCC(C1_1);A1_1;DDD(145))dfg
dfgdfgdfg,BBB(B1_1; CCC(C1_1); B1_2) sfsgndf
dfgnhjdfglkjdfg DDD(D1_1)
CCC()
one two 12AAA(CCC(C1_1; DDD(D1_1));A1_1)dfg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)