#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(090|080|070)-\d{4}-\d{4}$"
Local $sString = "===============" & @CRLF & _
" Match" & @CRLF & _
"===============" & @CRLF & _
"090-1234-5678" & @CRLF & _
"080-1234-5678" & @CRLF & _
"070-1234-5678" & @CRLF & _
"090-9999-9999" & @CRLF & _
"090-0000-0000" & @CRLF & _
"" & @CRLF & _
"===============" & @CRLF & _
" Not match" & @CRLF & _
"===============" & @CRLF & _
"060-1234-5678" & @CRLF & _
"090-A234-5678" & @CRLF & _
"090-1234-567" & @CRLF & _
"090-123-5678" & @CRLF & _
"09012345678" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")