import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(090|080|070)-\\d{4}-\\d{4}$";
final String string = "===============\n"
+ " Match\n"
+ "===============\n"
+ "090-1234-5678\n"
+ "080-1234-5678\n"
+ "070-1234-5678\n"
+ "090-9999-9999\n"
+ "090-0000-0000\n\n"
+ "===============\n"
+ " Not match\n"
+ "===============\n"
+ "060-1234-5678\n"
+ "090-A234-5678\n"
+ "090-1234-567\n"
+ "090-123-5678\n"
+ "09012345678\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}