$re = '/^(090|080|070)-\d{4}-\d{4}$/m';
$str = '===============
Match
===============
090-1234-5678
080-1234-5678
070-1234-5678
090-9999-9999
090-0000-0000
===============
Not match
===============
060-1234-5678
090-A234-5678
090-1234-567
090-123-5678
09012345678
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);