#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:((?:\.|^).)|.)(?=.*@)"
Local $sString = "captain.am-e-r-ica@email.com" & @CRLF & _
"my-cutie.pie+here@email.com" & @CRLF & _
"tom.cat@email.com" & @CRLF & _
"cutie.pie@email.com" & @CRLF & _
"captain.america@email.com"
Local $sSubst = "$1*"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)