use strict;
my $str = 'captain.am-e-r-ica@email.com
my-cutie.pie+here@email.com
tom.cat@email.com
cutie.pie@email.com
captain.america@email.com';
my $regex = qr/(?:((?:\.|^).)|.)(?=.*@)/mp;
my $subst = '$1*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";