import Foundation
let pattern = #"(?:((?:\.|^).)|.)(?=.*@)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
captain.am-e-r-ica@email.com
my-cutie.pie+here@email.com
tom.cat@email.com
cutie.pie@email.com
captain.america@email.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1*"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)