package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9a-zA-Z]{32,34}`)
var str = `a37965dcd8421328a767c697448ed735`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}