package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[fF]iles\b[^*()]*(?:\([^()]*\))?\|\*(?<ext>\.[\w*]+)(?:[,;]\*(?<ext>\.[\w*]+))*`)
var str = `txt files \`(*.txt)|*.txt|All files (*.*)|*.*\`
Image Files\`|*.jpg;*.jpeg;*.png;\`
Excel Files \`(*.xls, *.xlsx)|*.xls;*.xlsx|CSV Files (*.csv)|*.csv\``
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}