import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z\\d]{8}-[a-zA-Z\\d]{4}-[a-zA-Z\\d]{8}-[a-zA-Z\\d]{12})";
final String string = "23311544-6311-43f4abd5-7e96ceaa29f2";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}