// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([a-zA-Z\d]{8}-[a-zA-Z\d]{4}-[a-zA-Z\d]{8}-[a-zA-Z\d]{12})").unwrap();
let string = "23311544-6311-43f4abd5-7e96ceaa29f2";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}