use strict;
my $str = '$_POST[\'INPUT\']';
my $regex = qr/\$_(.*?)\['(.*?)'\]/p;
my $subst = '$this->\\L$2->$1\\(\'\\U$2\\\')';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";