const regex = /(\.\w+)\1+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\.\\w+)\\1+$', 'gm')
const str = `myoutput.pdf
hello.pdf.pdf
byebye.txt
hey.txt.txt`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);