use strict;
my $str = 'myoutput.pdf
hello.pdf.pdf
byebye.txt
hey.txt.txt';
my $regex = qr/(\.\w+)\1+$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";