using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/backup/(ABC|ABD)$";
string input = @"/backup/ABC
/backup/ABD
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}